To download the software for NeoSOS to connect to your computer, please click on Download:

Once downloaded please open when the appointment is due.

 

 

Which operating systems are supported?

Windows

Client versions Server versions TeamViewer versions
Windows 98 TeamViewer 3-6
Windows ME TeamViewer 3-6
Windows NT 4.0 SP6a TeamViewer 3-6
Windows 2000 SP4 Server 2000 TeamViewer 3-8
Windows XP SP3 ¹ Server 2003 ¹ TeamViewer 3-13
Windows Vista ¹ Server 2008 ¹ TeamViewer 3-13
Windows 7 Server 2008 R2 TeamViewer 4-13
Windows 8.0 Server 2012 TeamViewer 7-13
Windows 8.1 Server 2012 R2 TeamViewer 9-13
Windows 10 v1507 (RTM)
TeamViewer 10-13
Windows 10 v1607 (Anniversary Update)
Server 2016 TeamViewer 11-13
Windows 10 v1703 (Creators Update)
TeamViewer 11-13
Windows 10 v1709 (Fall Creators Update) ² TeamViewer 12-13
Windows 10 v1803 (April 2018 Update) ² TeamViewer 13

 ¹ Internet Explorer 8.0 or later is required.

² Previous versions of TeamViewer may still function correctly on this version of Windows 10. However, we can only provide support for the TeamViewer versions specifically listed in this table.

 

macOS

Mac versions TeamViewer versions
Mac OS X 10.4 (Tiger) TeamViewer 3-7
Mac OS X 10.5 (Leopard) TeamViewer 5-7
Mac OS X 10.6 (Snow Leopard) TeamViewer 6-9
Mac OS X 10.7 (Lion) TeamViewer 6-11
OS X 10.8 (Mountain Lion) TeamViewer 7-12
OS X 10.9 (Mavericks) TeamViewer 9-12
OS X 10.10 (Yosemite) TeamViewer 10-13
OS X 10.11 (El Capitan) TeamViewer 10-13
macOS 10.12 (Sierra) TeamViewer 11-13
macOS 10.13 (High Sierra) TeamViewer 12-13